$re = '/\[\s*(?P<key>\w+)+\s*]\s*(?P<value>[^[]*\s*)/m';
$str = '[aaa ] some text here [bbbb3 ] some other text here [cc ] more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);