// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\s*(?P<key>\w+)+\s*]\s*(?P<value>[^[]*\s*)").unwrap();
let string = "[aaa ] some text here [bbbb3 ] some other text here [cc ] more text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}