#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(\[.*?- SSR][^[]*)"
Local $sString = "some content here" & @CRLF & _
"[1/1/2015 - SSR] something" & @CRLF & _
"[1/2/2015 - SSR] another:" & @CRLF & _
"*something here" & @CRLF & _
"*another something here" & @CRLF & _
"[1/3/2015 - SSR] another one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")