import re
regex = re.compile(r"^(\[.*?- SSR][^[]*)", flags=re.DOTALL | re.MULTILINE)
test_str = ("some content here\n"
"[1/1/2015 - SSR] something\n"
"[1/2/2015 - SSR] another:\n"
"*something here\n"
"*another something here\n"
"[1/3/2015 - SSR] another one")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")