re = /^(\[.*?- SSR][^[]*)/m
str = 'some content here
[1/1/2015 - SSR] something
[1/2/2015 - SSR] another:
*something here
*another something here
[1/3/2015 - SSR] another one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end