package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:-+\w+)+|\w+(?:\.+\w+)*\.?|[^\w\s]+`)
var str = `k-11
b.....sc....
really???? k---11
b.s
b.s.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}