$re = '/\w+(?:-+\w+)+|\w+(?:\.+\w+)*\.?|[^\w\s]+/m';
$str = 'k-11
b.....sc....
really???? k---11
b.s
b.s.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);