re = /\w+(?:-+\w+)+|\w+(?:\.+\w+)*\.?|[^\w\s]+/m
str = 'k-11
b.....sc....
really???? k---11
b.s
b.s.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end