use strict;
my $str = ' 🗡️7️⃣8️⃣6️⃣🗡️ ';
my $regex = qr/[0-9]\p{M}+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";