$re = '/[0-9]\p{M}+/u';
$str = ' 🗡️7️⃣8️⃣6️⃣🗡️ ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;