const regex = /\[img width=.*?\].*?\[\/img\]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[img width=.*?\\].*?\\[\\\/img\\]', 'i')
const str = `<img src="test.jpg" width="" height="" />
<iframe src="somepage.html width="500" height="100"></iframe>
<img src="test2.jpg" width="" height="" />
[url=http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg][img width=499]http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg[/img][/url][br /]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}