re = /\[img width=.*?\].*?\[\/img\]/i
str = '<img src="test.jpg" width="" height="" />
<iframe src="somepage.html width="500" height="100"></iframe>
<img src="test2.jpg" width="" height="" />
[url=http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg][img width=499]http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg[/img][/url][br /]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end