using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\d\-|\._ ]*(?:(?<!universal)(\.jar)|(\.litemod))";
string input = @"Link_Info-mc1.7.10-0.3.1.litemod
Mantle-1.7.10-0.3.2.jar
MicdoodleCore-1.7-3.0.11.333.jar
MineTweaker3-1.7.10-3.0.9C.jar
ModTweaker 2-0.8.0.jar
MouseTweaks-2.4.4-mc1.7.10.jar
NEIIntegration-MC1.7.10-1.0.9.jar
NotEnoughItems-1.7.10-1.0.5.110-universal.jar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}