$re = '/[\w\d\-|\._ ]*(?:(?<!universal)(\.jar)|(\.litemod))/m';
$str = 'Link_Info-mc1.7.10-0.3.1.litemod
Mantle-1.7.10-0.3.2.jar
MicdoodleCore-1.7-3.0.11.333.jar
MineTweaker3-1.7.10-3.0.9C.jar
ModTweaker 2-0.8.0.jar
MouseTweaks-2.4.4-mc1.7.10.jar
NEIIntegration-MC1.7.10-1.0.9.jar
NotEnoughItems-1.7.10-1.0.5.110-universal.jar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);