import Foundation
let pattern = #"[\w\d\-|\._ ]*(?:(?<!universal)(\.jar)|(\.litemod))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Link_Info-mc1.7.10-0.3.1.litemod
Mantle-1.7.10-0.3.2.jar
MicdoodleCore-1.7-3.0.11.333.jar
MineTweaker3-1.7.10-3.0.9C.jar
ModTweaker 2-0.8.0.jar
MouseTweaks-2.4.4-mc1.7.10.jar
NEIIntegration-MC1.7.10-1.0.9.jar
NotEnoughItems-1.7.10-1.0.5.110-universal.jar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)