import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Rx\\s)([0-f0-9]+)\\s([0-f0-9]+\\s)+";
final String string = " 0.010011 1 AC Rx d 8 A0 AF 82 82 83 86 7F 00\\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}