const regex = /cur rent/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cur rent', '')
const str = `cur rent current hello there is there the possibility to go under the new online system that will give us the ongoing thrust for any new maintenance in the condo?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}