import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?P<table> # To match nested table tags\n"
+ " <table\\b[^>]*>\n"
+ " (?:\n"
+ " (?!</?table\\b[^>]*>).\n"
+ " |\n"
+ " (?&table)\n"
+ " )*\n"
+ " </table\\s*>\n"
+ " )\n"
+ " (?P<paragraph> # To match nested p tags\n"
+ " <p\\b[^>]*>\n"
+ " (?:\n"
+ " (?!</?p\\b[^>]*>).\n"
+ " |\n"
+ " (?¶graph)\n"
+ " )*\n"
+ " </p\\s*>\n"
+ " )\n"
+ ")\n"
+ "(?&table)(*SKIP)(*FAIL) # Let's skip table tags\n"
+ "|\n"
+ "(?¶graph) # And match p tags";
final String string = "test <table><p>wuuut</p></table><p>foo bar</p> test1 <p>baz qux</p> test3";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}