re = /(?(DEFINE)
(?P<table> # To match nested table tags
<table\b[^>]*>
(?:
(?!<\/?table\b[^>]*>).
|
(?&table)
)*
<\/table\s*>
)
(?P<paragraph> # To match nested p tags
<p\b[^>]*>
(?:
(?!<\/?p\b[^>]*>).
|
(?¶graph)
)*
<\/p\s*>
)
)
(?&table)(*SKIP)(*FAIL) # Let's skip table tags
|
(?¶graph) # And match p tags/xi
str = 'test <table><p>wuuut</p></table><p>foo bar</p> test1 <p>baz qux</p> test3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end