const regex = new RegExp('(?(DEFINE)
(?P<table> # To match nested table tags
<table\\b[^>]*>
(?:
(?!</?table\\b[^>]*>).
|
(?&table)
)*
</table\\s*>
)
(?P<paragraph> # To match nested p tags
<p\\b[^>]*>
(?:
(?!</?p\\b[^>]*>).
|
(?¶graph)
)*
</p\\s*>
)
)
(?&table)(*SKIP)(*FAIL) # Let\\'s skip table tags
|
(?¶graph) # And match p tags', 'gsi')
const str = `test <table><p>wuuut</p></table><p>foo bar</p> test1 <p>baz qux</p> test3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}