$re = '/Error\=(?<ErrDesc>[^\|]+\|[^\|]+)/m';
$str = 'Error=REQUEST ERROR | request is not valid.|","time":"1707622073040"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);