// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Error\=(?<ErrDesc>[^\|]+\|[^\|]+)").unwrap();
let string = "Error=REQUEST ERROR | request is not valid.|\",\"time\":\"1707622073040\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}