re = /Error\=(?<ErrDesc>[^\|]+\|[^\|]+)/m
str = 'Error=REQUEST ERROR | request is not valid.|","time":"1707622073040"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end