#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+?@(?=[a-z0-9-]{0,61}\.[a-z]{2,})"
Local $sString = "user:pass@zxuz.com" & @CRLF & _
                "user@proxy.brew.opendnstest.com/customBlockUserInfo" & @CRLF & _
                "user:@proxy.brew1.opendnstest.com/customBlockUserInfo" & @CRLF & _
                "user:password@proxy.brew2.opendnstest.com/customBlockUserInfo" & @CRLF & _
                "ftp://cnn.example.com&story=breaking_news@foobar.com/top_story.htm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")