import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+?@(?=[a-z0-9-]{0,61}\\.[a-z]{2,})";
final String string = "user:pass@zxuz.com\n"
+ "user@proxy.brew.opendnstest.com/customBlockUserInfo\n"
+ "user:@proxy.brew1.opendnstest.com/customBlockUserInfo\n"
+ "user:password@proxy.brew2.opendnstest.com/customBlockUserInfo\n"
+ "ftp://cnn.example.com&story=breaking_news@foobar.com/top_story.htm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}