using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.(\w{3,})$";
string substitution = @"$1";
string input = @"http://www.w3schools.com/jsref/jsref_regexp_exec.asp
https://translate.google.com/#en/pt/Thank%20you%20Engr!%20That%20is%20awesome.php
www.facebook.com/index.asp";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}