# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\.(\w{3,})$"
test_str = ("http://www.w3schools.com/jsref/jsref_regexp_exec.asp\n"
"https://translate.google.com/#en/pt/Thank%20you%20Engr!%20That%20is%20awesome.php\n"
"www.facebook.com/index.asp")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.