// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi).*\.(\w{3,})$").unwrap();
let string = "http://www.w3schools.com/jsref/jsref_regexp_exec.asp
https://translate.google.com/#en/pt/Thank%20you%20Engr!%20That%20is%20awesome.php
www.facebook.com/index.asp";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}