#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "calc\(.*\)"
Local $sString = "h1 {" & @CRLF & _
" font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" h1 {" & @CRLF & _
" font-size: calc( " & @CRLF & _
" 1rem " & @CRLF & _
" * 1.26 " & @CRLF & _
" * 1.26" & @CRLF & _
" * 1.26" & @CRLF & _
" );" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")