const regex = /calc\(.*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('calc\\(.*\\)', '')
const str = `h1 {
font-size: calc( 1rem * 1.26 * 1.26 * 1.26 );
}
h1 {
font-size: calc(
1rem
* 1.26
* 1.26
* 1.26
);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}