using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\w+(?:\s|\.))+\s+){2}";
string input = @"The Smithsonian museum is home to a variety of different art displays. According various reports art appreciation is on the rise. Blah blah blah blah.The Smithsonian museum blah blah blah. Blah blah blah blah.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}