re = /^((?:\w+(?:\s|\.))+\s+){2}/
str = 'The Smithsonian museum is home to a variety of different art displays. According various reports art appreciation is on the rise. Blah blah blah blah.The Smithsonian museum blah blah blah. Blah blah blah blah.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end