import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)\\s+([a-zA-Z0-9\\s]+\\d{2}:\\d{2}:\\d{2}\\s+[A-Za-z]+\\s+\\d{4})\\s+(.+)/(.+)";
final String string = "45013 Thu Aug 15 19:42:38 IST 2013 com/chilkatsoft/CkEmail.class";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}