const regex = new RegExp('^(\\d+)\\s+([a-zA-Z0-9\\s]+\\d{2}:\\d{2}:\\d{2}\\s+[A-Za-z]+\\s+\\d{4})\\s+(.+)/(.+)', 'g')
const str = `45013 Thu Aug 15 19:42:38 IST 2013 com/chilkatsoft/CkEmail.class`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}