using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+) = (.+) \+ (.+)";
string input = @"5 = 1 + 4
huhu = test + yeah
abc13d = a e t + h1u u";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}