$re = '/(.+) = (.+) \+ (.+)/';
$str = '5 = 1 + 4
huhu = test + yeah
abc13d = a e t + h1u u';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);