re = /(.+) = (.+) \+ (.+)/
str = '5 = 1 + 4
huhu = test + yeah
abc13d = a e t + h1u u'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end