#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<=^)|(?<=\D))((00|\+)?55(\s|\.|-)*)?((\()?0?\d{2}(?(5)\)|)(\s|\.|-)*)?(9(\s|\.|-)*)?\d{4}(\s|\.|-)*\d{4}(?=\D|$)"
Local $sString = "98993132" & @CRLF & _
"9899-3132" & @CRLF & _
"9899.3132" & @CRLF & _
"9899 3132" & @CRLF & _
"7198993132" & @CRLF & _
"719899-3132" & @CRLF & _
"719899.3132" & @CRLF & _
"719899 3132" & @CRLF & _
"71 98993132" & @CRLF & _
"71 9899-3132" & @CRLF & _
"71 9899.3132" & @CRLF & _
"71 9899 3132" & @CRLF & _
"071 98993132" & @CRLF & _
"071 9899-3132" & @CRLF & _
"071 9899.3132" & @CRLF & _
"071 9899 3132" & @CRLF & _
"(71)98993132" & @CRLF & _
"(71)9899-3132" & @CRLF & _
"(71)9899.3132" & @CRLF & _
"(71)9899 3132" & @CRLF & _
"(71) 98993132" & @CRLF & _
"(71) 9899-3132" & @CRLF & _
"(71) 9899.3132" & @CRLF & _
"(071) 9899 3132" & @CRLF & _
"(071) 98993132" & @CRLF & _
"(071) 9899-3132" & @CRLF & _
"(071) 9899.3132" & @CRLF & _
"(071) 9899 3132" & @CRLF & _
"557198993132" & @CRLF & _
"55719899-3132" & @CRLF & _
"55719899.3132" & @CRLF & _
"55719899 3132" & @CRLF & _
"5571 98993132" & @CRLF & _
"5571 9899-3132" & @CRLF & _
"5571 9899.3132" & @CRLF & _
"5571 9899 3132" & @CRLF & _
"55071 98993132" & @CRLF & _
"55071 9899-3132" & @CRLF & _
"55071 9899.3132" & @CRLF & _
"55071 9899 3132" & @CRLF & _
"55(71)98993132" & @CRLF & _
"55(71)9899-3132" & @CRLF & _
"55(71)9899.3132" & @CRLF & _
"55(71)9899 3132" & @CRLF & _
"55(71) 98993132" & @CRLF & _
"55(71) 9899-3132" & @CRLF & _
"55(71) 9899.3132" & @CRLF & _
"55(071) 9899 3132" & @CRLF & _
"55(071) 98993132" & @CRLF & _
"55(071) 9899-3132" & @CRLF & _
"55(071) 9899.3132" & @CRLF & _
"55(071) 9899 3132" & @CRLF & _
"55 7198993132" & @CRLF & _
"55 719899-3132" & @CRLF & _
"55 719899.3132" & @CRLF & _
"55 719899 3132" & @CRLF & _
"55 71 98993132" & @CRLF & _
"55 71 9899-3132" & @CRLF & _
"55 71 9899.3132" & @CRLF & _
"55 71 9899 3132" & @CRLF & _
"55 071 98993132" & @CRLF & _
"55 071 9899-3132" & @CRLF & _
"55 071 9899.3132" & @CRLF & _
"55 071 9899 3132" & @CRLF & _
"55 (71)98993132" & @CRLF & _
"55 (71)9899-3132" & @CRLF & _
"55 (71)9899.3132" & @CRLF & _
"55 (71)9899 3132" & @CRLF & _
"55 (71) 98993132" & @CRLF & _
"55 (71) 9899-3132" & @CRLF & _
"55 (71) 9899.3132" & @CRLF & _
"55 (071) 9899 3132" & @CRLF & _
"55 (071) 98993132" & @CRLF & _
"55 (071) 9899-3132" & @CRLF & _
"55 (071) 9899.3132" & @CRLF & _
"55 (071) 9899 3132" & @CRLF & _
"+557198993132" & @CRLF & _
"+55719899-3132" & @CRLF & _
"+55719899.3132" & @CRLF & _
"+55719899 3132" & @CRLF & _
"+5571 98993132" & @CRLF & _
"+5571 9899-3132" & @CRLF & _
"+5571 9899.3132" & @CRLF & _
"+5571 9899 3132" & @CRLF & _
"+55071 98993132" & @CRLF & _
"+55071 9899-3132" & @CRLF & _
"+55071 9899.3132" & @CRLF & _
"+55071 9899 3132" & @CRLF & _
"+55(71)98993132" & @CRLF & _
"+55(71)9899-3132" & @CRLF & _
"+55(71)9899.3132" & @CRLF & _
"+55(71)9899 3132" & @CRLF & _
"+55(71) 98993132" & @CRLF & _
"+55(71) 9899-3132" & @CRLF & _
"+55(71) 9899.3132" & @CRLF & _
"+55(071) 9899 3132" & @CRLF & _
"+55(071) 98993132" & @CRLF & _
"+55(071) 9899-3132" & @CRLF & _
"+55(071) 9899.3132" & @CRLF & _
"+55(071) 9899 3132" & @CRLF & _
"+55 7198993132" & @CRLF & _
"+55 719899-3132" & @CRLF & _
"+55 719899.3132" & @CRLF & _
"+55 719899 3132" & @CRLF & _
"+55 71 98993132" & @CRLF & _
"+55 71 9899-3132" & @CRLF & _
"+55 71 9899.3132" & @CRLF & _
"+55 71 9899 3132" & @CRLF & _
"+55 071 98993132" & @CRLF & _
"+55 071 9899-3132" & @CRLF & _
"+55 071 9899.3132" & @CRLF & _
"+55 071 9899 3132" & @CRLF & _
"+55 (71)98993132" & @CRLF & _
"+55 (71)9899-3132" & @CRLF & _
"+55 (71)9899.3132" & @CRLF & _
"+55 (71)9899 3132" & @CRLF & _
"+55 (71) 98993132" & @CRLF & _
"+55 (71) 9899-3132" & @CRLF & _
"+55 (71) 9899.3132" & @CRLF & _
"+55 (071) 9899 3132" & @CRLF & _
"+55 (071) 98993132" & @CRLF & _
"+55 (071) 9899-3132" & @CRLF & _
"+55 (071) 9899.3132" & @CRLF & _
"+55 (071) 9899 3132" & @CRLF & _
"998993132" & @CRLF & _
"99899-3132" & @CRLF & _
"99899.3132" & @CRLF & _
"99899 3132" & @CRLF & _
"71998993132" & @CRLF & _
"7199899-3132" & @CRLF & _
"7199899.3132" & @CRLF & _
"7199899 3132" & @CRLF & _
"71 998993132" & @CRLF & _
"71 99899-3132" & @CRLF & _
"71 99899.3132" & @CRLF & _
"71 99899 3132" & @CRLF & _
"071 998993132" & @CRLF & _
"071 99899-3132" & @CRLF & _
"071 99899.3132" & @CRLF & _
"071 99899 3132" & @CRLF & _
"(71)998993132" & @CRLF & _
"(71)99899-3132" & @CRLF & _
"(71)99899.3132" & @CRLF & _
"(71)99899 3132" & @CRLF & _
"(71) 998993132" & @CRLF & _
"(71) 99899-3132" & @CRLF & _
"(71) 99899.3132" & @CRLF & _
"(071) 99899 3132" & @CRLF & _
"(071) 998993132" & @CRLF & _
"(071) 99899-3132" & @CRLF & _
"(071) 99899.3132" & @CRLF & _
"(071) 99899 3132" & @CRLF & _
"5571998993132" & @CRLF & _
"557199899-3132" & @CRLF & _
"557199899.3132" & @CRLF & _
"557199899 3132" & @CRLF & _
"5571 998993132" & @CRLF & _
"5571 99899-3132" & @CRLF & _
"5571 99899.3132" & @CRLF & _
"5571 99899 3132" & @CRLF & _
"55071 998993132" & @CRLF & _
"55071 99899-3132" & @CRLF & _
"55071 99899.3132" & @CRLF & _
"55071 99899 3132" & @CRLF & _
"55(71)998993132" & @CRLF & _
"55(71)99899-3132" & @CRLF & _
"55(71)99899.3132" & @CRLF & _
"55(71)99899 3132" & @CRLF & _
"55(71) 998993132" & @CRLF & _
"55(71) 99899-3132" & @CRLF & _
"55(71) 99899.3132" & @CRLF & _
"55(071) 99899 3132" & @CRLF & _
"55(071) 998993132" & @CRLF & _
"55(071) 99899-3132" & @CRLF & _
"55(071) 99899.3132" & @CRLF & _
"55(071) 99899 3132" & @CRLF & _
"55 71998993132" & @CRLF & _
"55 7199899-3132" & @CRLF & _
"55 7199899.3132" & @CRLF & _
"55 7199899 3132" & @CRLF & _
"55 71 998993132" & @CRLF & _
"55 71 99899-3132" & @CRLF & _
"55 71 99899.3132" & @CRLF & _
"55 71 99899 3132" & @CRLF & _
"55 071 998993132" & @CRLF & _
"55 071 99899-3132" & @CRLF & _
"55 071 99899.3132" & @CRLF & _
"55 071 99899 3132" & @CRLF & _
"55 (71)998993132" & @CRLF & _
"55 (71)99899-3132" & @CRLF & _
"55 (71)99899.3132" & @CRLF & _
"55 (71)99899 3132" & @CRLF & _
"55 (71) 998993132" & @CRLF & _
"55 (71) 99899-3132" & @CRLF & _
"55 (71) 99899.3132" & @CRLF & _
"55 (071) 99899 3132" & @CRLF & _
"55 (071) 998993132" & @CRLF & _
"55 (071) 99899-3132" & @CRLF & _
"55 (071) 99899.3132" & @CRLF & _
"55 (071) 99899 3132" & @CRLF & _
"+5571998993132" & @CRLF & _
"+557199899-3132" & @CRLF & _
"+557199899.3132" & @CRLF & _
"+557199899 3132" & @CRLF & _
"+5571 998993132" & @CRLF & _
"+5571 99899-3132" & @CRLF & _
"+5571 99899.3132" & @CRLF & _
"+5571 99899 3132" & @CRLF & _
"+55071 998993132" & @CRLF & _
"+55071 99899-3132" & @CRLF & _
"+55071 99899.3132" & @CRLF & _
"+55071 99899 3132" & @CRLF & _
"+55(71)998993132" & @CRLF & _
"+55(71)99899-3132" & @CRLF & _
"+55(71)99899.3132" & @CRLF & _
"+55(71)99899 3132" & @CRLF & _
"+55(71) 998993132" & @CRLF & _
"+55(71) 99899-3132" & @CRLF & _
"+55(71) 99899.3132" & @CRLF & _
"+55(071) 99899 3132" & @CRLF & _
"+55(071) 998993132" & @CRLF & _
"+55(071) 99899-3132" & @CRLF & _
"+55(071) 99899.3132" & @CRLF & _
"+55(071) 99899 3132" & @CRLF & _
"+55 71998993132" & @CRLF & _
"+55 7199899-3132" & @CRLF & _
"+55 7199899.3132" & @CRLF & _
"+55 7199899 3132" & @CRLF & _
"+55 71 998993132" & @CRLF & _
"+55 71 99899-3132" & @CRLF & _
"+55 71 99899.3132" & @CRLF & _
"+55 71 99899 3132" & @CRLF & _
"+55 071 998993132" & @CRLF & _
"+55 071 99899-3132" & @CRLF & _
"+55 071 99899.3132" & @CRLF & _
"+55 071 99899 3132" & @CRLF & _
"+55 (71)998993132" & @CRLF & _
"+55 (71)99899-3132" & @CRLF & _
"+55 (71)99899.3132" & @CRLF & _
"+55 (71)99899 3132" & @CRLF & _
"+55 (71) 998993132" & @CRLF & _
"+55 (71) 99899-3132" & @CRLF & _
"+55 (71) 99899.3132" & @CRLF & _
"+55 (071) 99899 3132" & @CRLF & _
"+55 (071) 998993132" & @CRLF & _
"+55 (071) 99899-3132" & @CRLF & _
"+55 (071) 99899.3132" & @CRLF & _
"+55 (071) 99899 3132" & @CRLF & _
"9 98993132" & @CRLF & _
"9 9899-3132" & @CRLF & _
"9 9899.3132" & @CRLF & _
"9 9899 3132" & @CRLF & _
"719 98993132" & @CRLF & _
"719 9899-3132" & @CRLF & _
"719 9899.3132" & @CRLF & _
"719 9899 3132" & @CRLF & _
"71 9 98993132" & @CRLF & _
"71 9 9899-3132" & @CRLF & _
"71 9 9899.3132" & @CRLF & _
"71 9 9899 3132" & @CRLF & _
"071 9 98993132" & @CRLF & _
"071 9 9899-3132" & @CRLF & _
"071 9 9899.3132" & @CRLF & _
"071 9 9899 3132" & @CRLF & _
"(71)9 98993132" & @CRLF & _
"(71)9 9899-3132" & @CRLF & _
"(71)9 9899.3132" & @CRLF & _
"(71)9 9899 3132" & @CRLF & _
"(71) 9 98993132" & @CRLF & _
"(71) 9 9899-3132" & @CRLF & _
"(71) 9 9899.3132" & @CRLF & _
"(071) 9 9899 3132" & @CRLF & _
"(071) 9 98993132" & @CRLF & _
"(071) 9 9899-3132" & @CRLF & _
"(071) 9 9899.3132" & @CRLF & _
"(071) 9 9899 3132" & @CRLF & _
"55719 98993132" & @CRLF & _
"55719 9899-3132" & @CRLF & _
"55719 9899.3132" & @CRLF & _
"55719 9899 3132" & @CRLF & _
"5571 9 98993132" & @CRLF & _
"5571 9 9899-3132" & @CRLF & _
"5571 9 9899.3132" & @CRLF & _
"5571 9 9899 3132" & @CRLF & _
"55071 9 98993132" & @CRLF & _
"55071 9 9899-3132" & @CRLF & _
"55071 9 9899.3132" & @CRLF & _
"55071 9 9899 3132" & @CRLF & _
"55(71)9 98993132" & @CRLF & _
"55(71)9 9899-3132" & @CRLF & _
"55(71)9 9899.3132" & @CRLF & _
"55(71)9 9899 3132" & @CRLF & _
"55(71) 9 98993132" & @CRLF & _
"55(71) 9 9899-3132" & @CRLF & _
"55(71) 9 9899.3132" & @CRLF & _
"55(071) 9 9899 3132" & @CRLF & _
"55(071) 9 98993132" & @CRLF & _
"55(071) 9 9899-3132" & @CRLF & _
"55(071) 9 9899.3132" & @CRLF & _
"55(071) 9 9899 3132" & @CRLF & _
"55 719 98993132" & @CRLF & _
"55 719 9899-3132" & @CRLF & _
"55 719 9899.3132" & @CRLF & _
"55 719 9899 3132" & @CRLF & _
"55 71 9 98993132" & @CRLF & _
"55 71 9 9899-3132" & @CRLF & _
"55 71 9 9899.3132" & @CRLF & _
"55 71 9 9899 3132" & @CRLF & _
"55 071 9 98993132" & @CRLF & _
"55 071 9 9899-3132" & @CRLF & _
"55 071 9 9899.3132" & @CRLF & _
"55 071 9 9899 3132" & @CRLF & _
"55 (71)9 98993132" & @CRLF & _
"55 (71)9 9899-3132" & @CRLF & _
"55 (71)9 9899.3132" & @CRLF & _
"55 (71)9 9899 3132" & @CRLF & _
"55 (71) 9 98993132" & @CRLF & _
"55 (71) 9 9899-3132" & @CRLF & _
"55 (71) 9 9899.3132" & @CRLF & _
"55 (071) 9 9899 3132" & @CRLF & _
"55 (071) 9 98993132" & @CRLF & _
"55 (071) 9 9899-3132" & @CRLF & _
"55 (071) 9 9899.3132" & @CRLF & _
"55 (071) 9 9899 3132" & @CRLF & _
"+55719 98993132" & @CRLF & _
"+55719 9899-3132" & @CRLF & _
"+55719 9899.3132" & @CRLF & _
"+55719 9899 3132" & @CRLF & _
"+5571 9 98993132" & @CRLF & _
"+5571 9 9899-3132" & @CRLF & _
"+5571 9 9899.3132" & @CRLF & _
"+5571 9 9899 3132" & @CRLF & _
"+55071 9 98993132" & @CRLF & _
"+55071 9 9899-3132" & @CRLF & _
"+55071 9 9899.3132" & @CRLF & _
"+55071 9 9899 3132" & @CRLF & _
"+55(71)9 98993132" & @CRLF & _
"+55(71)9 9899-3132" & @CRLF & _
"+55(71)9 9899.3132" & @CRLF & _
"+55(71)9 9899 3132" & @CRLF & _
"+55(71) 9 98993132" & @CRLF & _
"+55(71) 9 9899-3132" & @CRLF & _
"+55(71) 9 9899.3132" & @CRLF & _
"+55(071) 9 9899 3132" & @CRLF & _
"+55(071) 9 98993132" & @CRLF & _
"+55(071) 9 9899-3132" & @CRLF & _
"+55(071) 9 9899.3132" & @CRLF & _
"+55(071) 9 9899 3132" & @CRLF & _
"+55 719 98993132" & @CRLF & _
"+55 719 9899-3132" & @CRLF & _
"+55 719 9899.3132" & @CRLF & _
"+55 719 9899 3132" & @CRLF & _
"+55 71 9 98993132" & @CRLF & _
"+55 71 9 9899-3132" & @CRLF & _
"+55 71 9 9899.3132" & @CRLF & _
"+55 71 9 9899 3132" & @CRLF & _
"+55 071 9 98993132" & @CRLF & _
"+55 071 9 9899-3132" & @CRLF & _
"+55 071 9 9899.3132" & @CRLF & _
"+55 071 9 9899 3132" & @CRLF & _
"+55 (71)9 98993132" & @CRLF & _
"+55 (71)9 9899-3132" & @CRLF & _
"+55 (71)9 9899.3132" & @CRLF & _
"+55 (71)9 9899 3132" & @CRLF & _
"+55 (71) 9 98993132" & @CRLF & _
"+55 (71) 9 9899-3132" & @CRLF & _
"+55 (71) 9 9899.3132" & @CRLF & _
"+55 (071) 9 9899 3132" & @CRLF & _
"+55 (071) 9 98993132" & @CRLF & _
"+55 (071) 9 9899-3132" & @CRLF & _
"+55 (071) 9 9899.3132" & @CRLF & _
"+55 (071) 9 9899 3132" & @CRLF & _
"" & @CRLF & _
"====== partial matches =======" & @CRLF & _
"55(71 9 7676-3131" & @CRLF & _
"55 (71 7676-3131" & @CRLF & _
"porque76763131sera" & @CRLF & _
"" & @CRLF & _
"======== no matches ==========" & @CRLF & _
"41650-010" & @CRLF & _
"123.456.789-00" & @CRLF & _
"123456789-00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")