# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=^)|(?<=\D))((00|\+)?55(\s|\.|-)*)?((\()?0?\d{2}(?(5)\)|)(\s|\.|-)*)?(9(\s|\.|-)*)?\d{4}(\s|\.|-)*\d{4}(?=\D|$)"
test_str = ("98993132\n"
"9899-3132\n"
"9899.3132\n"
"9899 3132\n"
"7198993132\n"
"719899-3132\n"
"719899.3132\n"
"719899 3132\n"
"71 98993132\n"
"71 9899-3132\n"
"71 9899.3132\n"
"71 9899 3132\n"
"071 98993132\n"
"071 9899-3132\n"
"071 9899.3132\n"
"071 9899 3132\n"
"(71)98993132\n"
"(71)9899-3132\n"
"(71)9899.3132\n"
"(71)9899 3132\n"
"(71) 98993132\n"
"(71) 9899-3132\n"
"(71) 9899.3132\n"
"(071) 9899 3132\n"
"(071) 98993132\n"
"(071) 9899-3132\n"
"(071) 9899.3132\n"
"(071) 9899 3132\n"
"557198993132\n"
"55719899-3132\n"
"55719899.3132\n"
"55719899 3132\n"
"5571 98993132\n"
"5571 9899-3132\n"
"5571 9899.3132\n"
"5571 9899 3132\n"
"55071 98993132\n"
"55071 9899-3132\n"
"55071 9899.3132\n"
"55071 9899 3132\n"
"55(71)98993132\n"
"55(71)9899-3132\n"
"55(71)9899.3132\n"
"55(71)9899 3132\n"
"55(71) 98993132\n"
"55(71) 9899-3132\n"
"55(71) 9899.3132\n"
"55(071) 9899 3132\n"
"55(071) 98993132\n"
"55(071) 9899-3132\n"
"55(071) 9899.3132\n"
"55(071) 9899 3132\n"
"55 7198993132\n"
"55 719899-3132\n"
"55 719899.3132\n"
"55 719899 3132\n"
"55 71 98993132\n"
"55 71 9899-3132\n"
"55 71 9899.3132\n"
"55 71 9899 3132\n"
"55 071 98993132\n"
"55 071 9899-3132\n"
"55 071 9899.3132\n"
"55 071 9899 3132\n"
"55 (71)98993132\n"
"55 (71)9899-3132\n"
"55 (71)9899.3132\n"
"55 (71)9899 3132\n"
"55 (71) 98993132\n"
"55 (71) 9899-3132\n"
"55 (71) 9899.3132\n"
"55 (071) 9899 3132\n"
"55 (071) 98993132\n"
"55 (071) 9899-3132\n"
"55 (071) 9899.3132\n"
"55 (071) 9899 3132\n"
"+557198993132\n"
"+55719899-3132\n"
"+55719899.3132\n"
"+55719899 3132\n"
"+5571 98993132\n"
"+5571 9899-3132\n"
"+5571 9899.3132\n"
"+5571 9899 3132\n"
"+55071 98993132\n"
"+55071 9899-3132\n"
"+55071 9899.3132\n"
"+55071 9899 3132\n"
"+55(71)98993132\n"
"+55(71)9899-3132\n"
"+55(71)9899.3132\n"
"+55(71)9899 3132\n"
"+55(71) 98993132\n"
"+55(71) 9899-3132\n"
"+55(71) 9899.3132\n"
"+55(071) 9899 3132\n"
"+55(071) 98993132\n"
"+55(071) 9899-3132\n"
"+55(071) 9899.3132\n"
"+55(071) 9899 3132\n"
"+55 7198993132\n"
"+55 719899-3132\n"
"+55 719899.3132\n"
"+55 719899 3132\n"
"+55 71 98993132\n"
"+55 71 9899-3132\n"
"+55 71 9899.3132\n"
"+55 71 9899 3132\n"
"+55 071 98993132\n"
"+55 071 9899-3132\n"
"+55 071 9899.3132\n"
"+55 071 9899 3132\n"
"+55 (71)98993132\n"
"+55 (71)9899-3132\n"
"+55 (71)9899.3132\n"
"+55 (71)9899 3132\n"
"+55 (71) 98993132\n"
"+55 (71) 9899-3132\n"
"+55 (71) 9899.3132\n"
"+55 (071) 9899 3132\n"
"+55 (071) 98993132\n"
"+55 (071) 9899-3132\n"
"+55 (071) 9899.3132\n"
"+55 (071) 9899 3132\n"
"998993132\n"
"99899-3132\n"
"99899.3132\n"
"99899 3132\n"
"71998993132\n"
"7199899-3132\n"
"7199899.3132\n"
"7199899 3132\n"
"71 998993132\n"
"71 99899-3132\n"
"71 99899.3132\n"
"71 99899 3132\n"
"071 998993132\n"
"071 99899-3132\n"
"071 99899.3132\n"
"071 99899 3132\n"
"(71)998993132\n"
"(71)99899-3132\n"
"(71)99899.3132\n"
"(71)99899 3132\n"
"(71) 998993132\n"
"(71) 99899-3132\n"
"(71) 99899.3132\n"
"(071) 99899 3132\n"
"(071) 998993132\n"
"(071) 99899-3132\n"
"(071) 99899.3132\n"
"(071) 99899 3132\n"
"5571998993132\n"
"557199899-3132\n"
"557199899.3132\n"
"557199899 3132\n"
"5571 998993132\n"
"5571 99899-3132\n"
"5571 99899.3132\n"
"5571 99899 3132\n"
"55071 998993132\n"
"55071 99899-3132\n"
"55071 99899.3132\n"
"55071 99899 3132\n"
"55(71)998993132\n"
"55(71)99899-3132\n"
"55(71)99899.3132\n"
"55(71)99899 3132\n"
"55(71) 998993132\n"
"55(71) 99899-3132\n"
"55(71) 99899.3132\n"
"55(071) 99899 3132\n"
"55(071) 998993132\n"
"55(071) 99899-3132\n"
"55(071) 99899.3132\n"
"55(071) 99899 3132\n"
"55 71998993132\n"
"55 7199899-3132\n"
"55 7199899.3132\n"
"55 7199899 3132\n"
"55 71 998993132\n"
"55 71 99899-3132\n"
"55 71 99899.3132\n"
"55 71 99899 3132\n"
"55 071 998993132\n"
"55 071 99899-3132\n"
"55 071 99899.3132\n"
"55 071 99899 3132\n"
"55 (71)998993132\n"
"55 (71)99899-3132\n"
"55 (71)99899.3132\n"
"55 (71)99899 3132\n"
"55 (71) 998993132\n"
"55 (71) 99899-3132\n"
"55 (71) 99899.3132\n"
"55 (071) 99899 3132\n"
"55 (071) 998993132\n"
"55 (071) 99899-3132\n"
"55 (071) 99899.3132\n"
"55 (071) 99899 3132\n"
"+5571998993132\n"
"+557199899-3132\n"
"+557199899.3132\n"
"+557199899 3132\n"
"+5571 998993132\n"
"+5571 99899-3132\n"
"+5571 99899.3132\n"
"+5571 99899 3132\n"
"+55071 998993132\n"
"+55071 99899-3132\n"
"+55071 99899.3132\n"
"+55071 99899 3132\n"
"+55(71)998993132\n"
"+55(71)99899-3132\n"
"+55(71)99899.3132\n"
"+55(71)99899 3132\n"
"+55(71) 998993132\n"
"+55(71) 99899-3132\n"
"+55(71) 99899.3132\n"
"+55(071) 99899 3132\n"
"+55(071) 998993132\n"
"+55(071) 99899-3132\n"
"+55(071) 99899.3132\n"
"+55(071) 99899 3132\n"
"+55 71998993132\n"
"+55 7199899-3132\n"
"+55 7199899.3132\n"
"+55 7199899 3132\n"
"+55 71 998993132\n"
"+55 71 99899-3132\n"
"+55 71 99899.3132\n"
"+55 71 99899 3132\n"
"+55 071 998993132\n"
"+55 071 99899-3132\n"
"+55 071 99899.3132\n"
"+55 071 99899 3132\n"
"+55 (71)998993132\n"
"+55 (71)99899-3132\n"
"+55 (71)99899.3132\n"
"+55 (71)99899 3132\n"
"+55 (71) 998993132\n"
"+55 (71) 99899-3132\n"
"+55 (71) 99899.3132\n"
"+55 (071) 99899 3132\n"
"+55 (071) 998993132\n"
"+55 (071) 99899-3132\n"
"+55 (071) 99899.3132\n"
"+55 (071) 99899 3132\n"
"9 98993132\n"
"9 9899-3132\n"
"9 9899.3132\n"
"9 9899 3132\n"
"719 98993132\n"
"719 9899-3132\n"
"719 9899.3132\n"
"719 9899 3132\n"
"71 9 98993132\n"
"71 9 9899-3132\n"
"71 9 9899.3132\n"
"71 9 9899 3132\n"
"071 9 98993132\n"
"071 9 9899-3132\n"
"071 9 9899.3132\n"
"071 9 9899 3132\n"
"(71)9 98993132\n"
"(71)9 9899-3132\n"
"(71)9 9899.3132\n"
"(71)9 9899 3132\n"
"(71) 9 98993132\n"
"(71) 9 9899-3132\n"
"(71) 9 9899.3132\n"
"(071) 9 9899 3132\n"
"(071) 9 98993132\n"
"(071) 9 9899-3132\n"
"(071) 9 9899.3132\n"
"(071) 9 9899 3132\n"
"55719 98993132\n"
"55719 9899-3132\n"
"55719 9899.3132\n"
"55719 9899 3132\n"
"5571 9 98993132\n"
"5571 9 9899-3132\n"
"5571 9 9899.3132\n"
"5571 9 9899 3132\n"
"55071 9 98993132\n"
"55071 9 9899-3132\n"
"55071 9 9899.3132\n"
"55071 9 9899 3132\n"
"55(71)9 98993132\n"
"55(71)9 9899-3132\n"
"55(71)9 9899.3132\n"
"55(71)9 9899 3132\n"
"55(71) 9 98993132\n"
"55(71) 9 9899-3132\n"
"55(71) 9 9899.3132\n"
"55(071) 9 9899 3132\n"
"55(071) 9 98993132\n"
"55(071) 9 9899-3132\n"
"55(071) 9 9899.3132\n"
"55(071) 9 9899 3132\n"
"55 719 98993132\n"
"55 719 9899-3132\n"
"55 719 9899.3132\n"
"55 719 9899 3132\n"
"55 71 9 98993132\n"
"55 71 9 9899-3132\n"
"55 71 9 9899.3132\n"
"55 71 9 9899 3132\n"
"55 071 9 98993132\n"
"55 071 9 9899-3132\n"
"55 071 9 9899.3132\n"
"55 071 9 9899 3132\n"
"55 (71)9 98993132\n"
"55 (71)9 9899-3132\n"
"55 (71)9 9899.3132\n"
"55 (71)9 9899 3132\n"
"55 (71) 9 98993132\n"
"55 (71) 9 9899-3132\n"
"55 (71) 9 9899.3132\n"
"55 (071) 9 9899 3132\n"
"55 (071) 9 98993132\n"
"55 (071) 9 9899-3132\n"
"55 (071) 9 9899.3132\n"
"55 (071) 9 9899 3132\n"
"+55719 98993132\n"
"+55719 9899-3132\n"
"+55719 9899.3132\n"
"+55719 9899 3132\n"
"+5571 9 98993132\n"
"+5571 9 9899-3132\n"
"+5571 9 9899.3132\n"
"+5571 9 9899 3132\n"
"+55071 9 98993132\n"
"+55071 9 9899-3132\n"
"+55071 9 9899.3132\n"
"+55071 9 9899 3132\n"
"+55(71)9 98993132\n"
"+55(71)9 9899-3132\n"
"+55(71)9 9899.3132\n"
"+55(71)9 9899 3132\n"
"+55(71) 9 98993132\n"
"+55(71) 9 9899-3132\n"
"+55(71) 9 9899.3132\n"
"+55(071) 9 9899 3132\n"
"+55(071) 9 98993132\n"
"+55(071) 9 9899-3132\n"
"+55(071) 9 9899.3132\n"
"+55(071) 9 9899 3132\n"
"+55 719 98993132\n"
"+55 719 9899-3132\n"
"+55 719 9899.3132\n"
"+55 719 9899 3132\n"
"+55 71 9 98993132\n"
"+55 71 9 9899-3132\n"
"+55 71 9 9899.3132\n"
"+55 71 9 9899 3132\n"
"+55 071 9 98993132\n"
"+55 071 9 9899-3132\n"
"+55 071 9 9899.3132\n"
"+55 071 9 9899 3132\n"
"+55 (71)9 98993132\n"
"+55 (71)9 9899-3132\n"
"+55 (71)9 9899.3132\n"
"+55 (71)9 9899 3132\n"
"+55 (71) 9 98993132\n"
"+55 (71) 9 9899-3132\n"
"+55 (71) 9 9899.3132\n"
"+55 (071) 9 9899 3132\n"
"+55 (071) 9 98993132\n"
"+55 (071) 9 9899-3132\n"
"+55 (071) 9 9899.3132\n"
"+55 (071) 9 9899 3132\n\n"
"====== partial matches =======\n"
"55(71 9 7676-3131\n"
"55 (71 7676-3131\n"
"porque76763131sera\n\n"
"======== no matches ==========\n"
"41650-010\n"
"123.456.789-00\n"
"123456789-00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.