using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*abc([0-9]+).*?jk";
string input = @"abc12..manycharshere...hi - abc23...manyothercharshere...jk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}