const regex = /.*abc([0-9]+).*?jk/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*abc([0-9]+).*?jk', 'g')
const str = `abc12..manycharshere...hi - abc23...manyothercharshere...jk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}