re = /.*abc([0-9]+).*?jk/
str = 'abc12..manycharshere...hi - abc23...manyothercharshere...jk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end