import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "['rocola'], r'([^ ]*\\K)'";
final String string = "rocola <-- that works then, r'' stuff inside should match infinite stuff separed by spaces, then python does the work\n"
+ "for example\n\n"
+ "rocola something another\n\n"
+ "the stuff inside r'' should match something, another, and all the stuff that goes after that, so python divides it into groups :O";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}