const regex = new RegExp('[\\'rocola\\'], r\\'([^ ]*\\K)\\'', '')
const str = `rocola <-- that works then, r'' stuff inside should match infinite stuff separed by spaces, then python does the work
for example
rocola something another
the stuff inside r'' should match something, another, and all the stuff that goes after that, so python divides it into groups :O`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}