$re = '/[\'rocola\'], r\'([^ ]*\K)\'/';
$str = 'rocola <-- that works then, r\'\' stuff inside should match infinite stuff separed by spaces, then python does the work
for example
rocola something another
the stuff inside r\'\' should match something, another, and all the stuff that goes after that, so python divides it into groups :O';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);