using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!@)STR";
string substitution = @"FOO";
string input = @" STR @STR #STR";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}