const regex = /(?<!@)STR/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!@)STR', 'g')
const str = ` STR @STR #STR`;
const subst = `FOO`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);