#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:e(?!\w*e)|t(?!(?:\w*t){2})|a(?!\w*a))+\b"
Local $sString = "For example the following would work:" & @CRLF & _
"" & @CRLF & _
"eat tea tate tt a e" & @CRLF & _
"" & @CRLF & _
"The following would not work" & @CRLF & _
"" & @CRLF & _
"eats teas tates ttt aa ee"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")