$re = '/\b(?:e(?!\w*e)|t(?!(?:\w*t){2})|a(?!\w*a))+\b/';
$str = 'For example the following would work:
eat tea tate tt a e
The following would not work
eats teas tates ttt aa ee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);