import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:e(?!\\w*e)|t(?!(?:\\w*t){2})|a(?!\\w*a))+\\b";
final String string = "For example the following would work:\n\n"
+ "eat tea tate tt a e\n\n"
+ "The following would not work\n\n"
+ "eats teas tates ttt aa ee";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}